Project

General

Profile

Wt Compiling Error

Added by John Robson over 7 years ago

Hi,

I'm using Arch Linux 64 bits, I already compiled other codes, but I cannot compile Wt, I got this error: http://paste.debian.net/143858/

I'm using this command:

$ cmake -D CMAKE_CXX_COMPILER="g" -D CMAKE_BUILD_TYPE="Release" -D CMAKE_CXX_FLAGS="-std=gnu++11 -march=corei7-avx -O2 -g0 -D NDEBUG -UNDEBUG" -D WT_CPP_11_MODE="-std=gnu++11" -D WT_WRASTERIMAGE_IMPLEMENTATION="GraphicsMagick" /srv/sources/git/wt

$ time nice -n 19 make -j ${threads}

Can someone help me?

Thank you,

John

ps.: I started PostgreSQL and MySQL DBs before compile.


Replies (4)

RE: Wt Compiling Error - Added by John Robson over 7 years ago

$ g -v

Using built-in specs.

COLLECT_GCC=/usr/bin/g

COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-unknown-linux-gnu/4.9.2/lto-wrapper

Target: x86_64-unknown-linux-gnu

Configured with: /build/gcc-multilib/src/gcc-4.9-20141224/configure ---prefix=/usr ---libdir=/usr/lib ---libexecdir=/usr/lib ---mandir=/usr/share/man ---infodir=/usr/share/info ---with-bugurl=https://bugs.archlinux.org/ ---enable-languages=c,c,ada,fortran,go,lto,objc,obj-c ---enable-shared ---enable-threads=posix ---with-system-zlib ---enable-__cxa_atexit ---disable-libunwind-exceptions ---enable-clocale=gnu ---disable-libstdcxx-pch ---disable-libssp ---enable-gnu-unique-object ---enable-linker-build-id ---enable-cloog-backend=isl ---enable-lto ---enable-plugin ---enable-install-libiberty ---with-linker-hash-style=gnu ---enable-multilib ---disable-werror ---enable-checking=release

Thread model: posix

gcc version 4.9.2 20141224 (prerelease) (GCC)

$ psql ---version

psql (PostgreSQL) 9.4.0

$ mysql -V

mysql Ver 15.1 Distrib 10.0.16-MariaDB, for Linux (x86_64) using readline 5.1

RE: Wt Compiling Error - Added by John Robson over 7 years ago

With these lines I got this error: http://paste.debian.net/144015/

I comment these lines and the compilation finish successful.

test/dbo/DboTest.C

149: //boost::optionalstd::string string3;

201: //if (string3 != other.string3) {

202: // DEBUG (std::cerr << \"ERROR: string3 = \" << string3 << \" | \"
203: // << other.string3 << std::endl);

269: //&& string3 == other.string3

296: //dbo::field(a, string3, "string3");

I'm using GCC 4.9.2, Boost 1.57.0, cmake 3.1.1, Arch Linux 64 bits

RE: Wt Compiling Error - Added by Wim Dumon over 7 years ago

Indeed a problem with operator<< and boost 1.57. A fix is on its way to github.

Wim.

RE: Wt Compiling Error - Added by John Robson over 7 years ago

I forgot to mention, I'm using Boost 1.57 ;)

Thank you.

John

    (1-4/4)