Project

General

Profile

Installing and Setting up Wt for Visual Studio

Added by Andile Cele 3 months ago

I want to create a web application using Wt, but I am struggling to set it up and start coding on my chosen IDE, which is Visual Studio 2022.

Can anyone please share how can I do it. I tried building with Cmake and I got errors in response. These are the errors:

Cmake Error at C:/Program Files/CMake/share/cmake-3.22/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
Could NOT find Boost (missing: Boost_INCLUDE_DIR program_options filesystem
thread) (Requires at least version "1.50')
Call Stack (most recent call first):
C:/Program Files/CMake/share/cmake-3.22/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
C:/Program Files/CMake/share/cmake-3.22/Modules/FindBoost.cmake: 2360 (find_package_handle_standard_args)
cmake/WtFindBoost/txt:92 (FIND_PACKAGE)
CMakeList.txt:241 (INCLUDE)

-- Configuring incomplete, errors occurred!
See also "C:/Users/Dell USER 1/Downloads/wt-4.8.0/CMakeFiles/CMakeOutput.log".
See also "C:/Users/Dell USER 1/Downloads/wt-4.8.0/CMakeFiles/CMakeError.log".


Replies (1)

RE: Installing and Setting up Wt for Visual Studio - Added by Stefan Arndt 3 months ago

Hi, just to be sure: Did you actually install "boost"? The message Could NOT find Boost indicates that it is missing or not configured properly.

Have a read here on how to get boost to work: https://www.boost.org/doc/libs/1_80_0/more/getting_started/windows.html

    (1-1/1)