Does not start jwt-hello with jwt-3.3.8

Added by Aleksey Anosov 5 months ago

Hello. I'm new at java web and jwt. I'm trying to launch the jwt-hello application with jwt-3.3.8 and I always get an error.

Log:
17-Jul-2017 10:42:48.421 INFO [http-nio-8084-exec-8] org.apache.catalina.core.ApplicationContext.log Marking servlet helloJWT as unavailable
17-Jul-2017 10:42:48.422 SEVERE [http-nio-8084-exec-8] org.apache.catalina.core.StandardWrapperValve.invoke Allocate exception for servlet helloJWT
java.lang.ClassNotFoundException: org.slf4j.LoggerFactory
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1333)
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1167)
at eu.webtoolkit.jwt.WtServlet.<clinit>(WtServlet.java:78)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
at java.lang.Class.newInstance(Class.java:442)
at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:121)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1095)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:817)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:135)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:106)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:502)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:142)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:79)
at org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:616)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:88)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:518)
at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1091)
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:673)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1500)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1456)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:748)

Apache Tomcat show: HTTP Status 500 - Error instantiating servlet class ...

When I try to start it with jwt-3.1.11 from maven repository, everything works. Why can it be?


Replies (2)

RE: Does not start jwt-hello with jwt-3.3.8 - Added by Aleksey Anosov 5 months ago

Everything is working. It was my fault. Sorry.

RE: Does not start jwt-hello with jwt-3.3.8 - Added by Wim Dumon 5 months ago

Aleksey,

Great :-) Thanks for letting us know.

Wim.

(1-2/2)