Project

General

Profile

Bug #1043

Wt::WFileUpload::uploaded() not emitted in Opera

Added by Jan Hrubeš about 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
10/31/2011
Due date:
% Done:

0%

Estimated time:

Description

Hi,

Wt::WFileUpload::uploaded() signal is not emitted in Opera browser (Presto/2.9.168 Version/11.52). In Firefox it is OK.

regards,

Jan


Files

HuUpload.cpp (930 Bytes) HuUpload.cpp Jan Hrubeš, 10/31/2011 11:22 PM
#1

Updated by Koen Deforche about 11 years ago

  • Status changed from New to Feedback
  • Assignee set to Koen Deforche
  • Target version set to 3.2.0

Hey,

I could not reproduce this bug with either:

  • Opera/9.80 (X11; Linux x86_64; U; en) Presto/2.9.168 Version/11.50
  • Opera/9.80 (Macintosh; Intel Mac OS X 10.6.8; U; en) Presto/2.9.168 Version/11.52

In both cases, progress goes to 100% and Done gets printed.

Perhaps there is another configuration option in your opera setup that breaks this ?

Regards,

koen

#2

Updated by Koen Deforche about 11 years ago

  • Target version changed from 3.2.0 to 3.2.1
#3

Updated by Jan Hrubeš about 11 years ago

Hi,

I have just downloaded a compiled Wt 3.2.0 and the problem in Opera persists. In Chrome and Firefox program works good.

Opera is still in version Opera/9.80 (X11; Linux x86_64; U; cs) Presto/2.9.168 Version/11.52.

regards,

Jan

#4

Updated by Koen Deforche about 11 years ago

Hey Jan,

I checked again. Opera really behaves correctly. Have you configured Opera in a special way, e.g. disabled JavaScript ?

Regards,

koen

#5

Updated by Jan Hrubeš about 11 years ago

Hi Koen,

I finally checked it on another PC (Opera/9.80 (X11; Linux x86_64; U; cs) Presto/2.10.229 Version/11.60) and it works well.

So it looks like issue in my PC. Another Wt based applications even with custom JavaScript runs well, but problem with uploaded() still persists (now with opera version 11.60).

thanks for support,

Jan

#6

Updated by Jan Hrubeš about 11 years ago

Here is an error message from JavaScript console from "broken" Opera.

[22.1.2012 23:12:53] JavaScript - http://127.0.0.1/?wtd=AasPo0aogqi8OnJ5&request=resource&resource=ogjbumb&rand=1

Event thread: load

Uncaught exception: ReferenceError: Security error: attempted to read protected variable: Wt

Error thrown at line 2, column 18 in load() in http://127.0.0.1/?wtd=AasPo0aogqi8OnJ5&request=resource&resource=ogjbumb&rand=1:

if (window.parent.Wt)

called from line 1, column 0 in (event) in http://127.0.0.1/?wtd=AasPo0aogqi8OnJ5&request=resource&resource=ogjbumb&rand=1:

load();

#7

Updated by Koen Deforche about 11 years ago

Hey Jan,

Thanks for your persistence. That error message is an eye opener!

What is the URL that you deploy at? Is it http://127.0.0.1/ ?

For some reason, a cross-domain security exception is thrown. But in fact, there is no cross-domain operation being done.

Googling on this indicates that it is a common problem with Opera, but with no clear resolution. One user indicated this:

Removing ~/.opera folder (Opera settings folder in Linux) solved this, and another one very weird problem

You might want to try that (not rm but mv ~/.opera) ?

Another workaround is to use HTML5 Messages, which can be used for cross-domain messaging, although in fact, this is not a cross-domain situation. We might try that next.

Cheers.

#8

Updated by Jan Hrubeš about 11 years ago

Hi Koen,

yes, I'm using localhost for building and debugging.

But from my last message the things goes even more weird.

The WFileUpload works now even in my Opera correct. There were only some Ubuntu updates, but the Opera is the same. I haven't touched ~/.opera . Maybe a ghost in my computer.

But I noticed a different issue.

Linker stops with error when linking HuUpload.cpp application (wt 3.2.0, boost 1.46.1)

Error message starts with:

/usr/local/lib/libwthttp.a(Server.o): In function `boost::asio::detail::posix_tss_ptr<boost::asio::detail::call_stack<boost::asio::detail::strand_service::strand_impl>::context>::operator=(boost::asio::detail::call_stack<boost::asio::detail::strand_service::strand_impl>::context*)':
/usr/local/include/boost/asio/detail/posix_tss_ptr.hpp:60: undefined reference to `pthread_setspecific'

and have about five pages similar messages. I'm using LDFLAGS+=-lpthread but it is not helping.

When I declare some std::string variable somewhere in any function the program works.

regards,

Jan

#9

Updated by Koen Deforche almost 11 years ago

Hey,

None of this makes sense :-)

Are you sure the -lpthread gets in the right place, in the linker command ? You could double check that ?

It really sounds like you're just missing -lpthread which may indeed be needed because you use static wt libraries.

Regards,

koen

#10

Updated by Koen Deforche almost 11 years ago

  • Status changed from Feedback to Closed

Closed --- remains a mystery, a glitch in the matrix perhaps.

Also available in: Atom PDF