Project

General

Profile

Bug #1092

compilation errors on Linux

Added by Anonymous almost 10 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Target version:
-
Start date:
12/12/2011
Due date:
% Done:

0%

Estimated time:

Description

/home/user/workspace/wt2/wt/examples/blog/model/Token.h(39): error: default argument is not allowed

DBO_EXTERN_TEMPLATES(Token);

^

/home/user/workspace/wt2/wt/examples/blog/model/Comment.h(58): error: default argument is not allowed

DBO_EXTERN_TEMPLATES(Comment);

^

/home/user/workspace/wt2/wt/examples/blog/model/Tag.h(37): error: default argument is not allowed

DBO_EXTERN_TEMPLATES(Tag);

^

/home/user/workspace/wt2/wt/examples/blog/model/Post.h(69): error: default argument is not allowed

DBO_EXTERN_TEMPLATES(Post);

^

/home/user/workspace/wt2/wt/examples/blog/model/User.h(70): error: default argument is not allowed

DBO_EXTERN_TEMPLATES(User);

^

#1

Updated by Koen Deforche almost 10 years ago

  • Status changed from New to Feedback

Hey,

Although I can guess the cause, I would be curious what compiler trips over this, so that we can include it in our build server ?

i.e. 'gcc ---version' ?

Regards,

koen

#2

Updated by Koen Deforche about 8 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF