Project

General

Profile

Bug #10942

Chart WigdetGallery

Added by Stefan Arndt 5 months ago. Updated 13 days ago.

Status:
Resolved
Priority:
Low
Target version:
Start date:
09/14/2022
Due date:
% Done:

100%

Estimated time:

Description

(Not a bug in wt itself but in the Widget Gallery.)

There are pages in the widget gallery that contain wrong links into the Wt reference:

https://www.webtoolkit.eu/widgets/graphics-charts/category-chart
https://www.webtoolkit.eu/widgets/graphics-charts/pie-chart
https://www.webtoolkit.eu/widgets/graphics-charts/3d-category-chart

It seems that most links into the chart namespace are wrong due to a missing namespace.
E.g. "CartesianChart" at the very top of https://www.webtoolkit.eu/widgets/graphics-charts/category-chart links to
https://www.webtoolkit.eu/wt/doc/reference/html/classWt_1_1WCartesianChart.html
instead of
https://www.webtoolkit.eu/wt/doc/reference/html/classWt_1_1Chart_1_1WCartesianChart.html

The links on the other pages in the "Graphics and Charts" chapter are correct,
e.g. in https://www.webtoolkit.eu/widgets/graphics-charts/3d-numerical-chart

The working links have the namespace "Chart" in the link text. This is missing on the pages with wrong link targets.

#1

Updated by Roel Standaert about 2 months ago

  • Status changed from New to InProgress
  • Assignee set to Roel Standaert
#2

Updated by Roel Standaert about 2 months ago

  • Status changed from InProgress to Review
  • Assignee changed from Roel Standaert to Korneel Dumon
  • Target version set to 4.10.0
#3

Updated by Roel Standaert 13 days ago

  • Status changed from Review to Implemented @Emweb
  • Assignee changed from Korneel Dumon to Roel Standaert
  • % Done changed from 0 to 100
#4

Updated by Roel Standaert 13 days ago

  • Status changed from Implemented @Emweb to Resolved

Also available in: Atom PDF