Project

General

Profile

Bug #1279

Browser path wrong after url with special chars in it

Added by Kurt Roeckx over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
05/01/2012
Due date:
% Done:

0%

Estimated time:

Description

Hi,

If I create an internal path and it for instance contains a space, it's encoded as "%20", but my browser (firefox) actually shows it to me as a space in the url bar.

If I leave this url to go to an other internal path, the url shown in the browser's url bar still contains part of the previous url.

Example: I go to "/foo%20bar", the browser shows "/foo bar", and then go to "/bar", the url will actually show "/f/bar"

If there are 2 such chars in the url, the amount of chars left from the previous url are 4.

So it seems to me Wt counts chars in the encoded form, the browser in the non-encoded form, and you try to remove chars from end.

Kurt

#1

Updated by Koen Deforche over 8 years ago

  • Status changed from New to InProgress
  • Assignee set to Wim Dumon
  • Target version set to 3.2.2

Wim, this seems a duplicate of http://redmine.emweb.be/issues/1256 ?

#2

Updated by Koen Deforche over 8 years ago

  • Target version changed from 3.2.2 to 3.2.3
#3

Updated by Kurt Roeckx about 8 years ago

Koen Deforche wrote:

Wim, this seems a duplicate of http://redmine.emweb.be/issues/1256 ?

That is unrelated.

#1256 is that if you set an internalPath with a char that doesn't need quoting, it gets quoted anyway. This wouldn't be a problem if we got back the unquoted string when looking at the internalPath.

This is about the url getting corrupt in the browser. The url in the html is correct, everything works, but ajax updates the url as shown by the browser wrong.

Kurt

#4

Updated by Koen Deforche almost 8 years ago

  • Target version changed from 3.2.3 to 3.3.0
#5

Updated by Koen Deforche over 7 years ago

  • Status changed from InProgress to Closed

Also available in: Atom PDF