Project

General

Profile

Bug #1382

Wt/WTextEdit Exception with Wt-3.2.2-p1

Added by Mamadou Babaei over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
08/01/2012
Due date:
% Done:

0%

Estimated time:

Description

It seems Wt-3.2.2-p1 is a buggy release, in 2 hours I discovered 2 major bugs in Wt

(One is with CSS rendering of my site which I solved using CSS, it's working with all past releases,

maybe it's not bug and something changed for good)

By the way there is a serious bug with Wt::WTextEdit.

When you initialize a new instance of a WTextEdit and add it to your page,

You'll see these errors and your application stops working.

userAgent: Mozilla/5.0 (X11; FreeBSD amd64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Error:

Wt internal error: TypeError: Cannot read property 'onpageload' of undefined, code: undefined, description: undefined

Wt internal error: TypeError: Cannot call method 'setAttribute' of null, code: undefined, description: undefined

Wt internal error: TypeError: Cannot read property 'getContext' of null, code: undefined, description: undefined

userAgent: Mozilla/5.0 (X11; FreeBSD amd64; rv:13.0) Gecko/20100101 Firefox/13.0.1

Error:

Wt internal error: TypeError: z is undefined, code: undefined, description: undefined

Wt internal error: TypeError: j1155 is null, code: undefined, description: undefined

Wt internal error: TypeError: Wt3_2_2.getElement("coe2wppy") is null, code: undefined, description: undefined

userAgent: Opera/9.80 (X11; Linux i686; U; en) Presto/2.10.229 Version/11.62

Error:

Wt internal error: TypeError: Cannot convert 'z' to object, code: undefined, description: undefined

Wt internal error: TypeError: Cannot convert 'j911' to object, code: undefined, description: undefined

#1

Updated by Mamadou Babaei over 10 years ago

I found the probelm.

The problem is TinyMCE 3.5.x. TinyMCE 3.4.9 works just fine.

#2

Updated by Koen Deforche over 10 years ago

  • Status changed from New to Resolved
  • Assignee set to Koen Deforche
  • Target version set to 3.2.2-p1
#3

Updated by Koen Deforche over 10 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 3.2.2-p1 to 3.2.3

Fixed in Wt 3.2.3 RC1.

Also available in: Atom PDF