Project

General

Profile

Bug #1458

Installing WT inWindows

Added by Anonymous about 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Immediate
Assignee:
Target version:
Start date:
10/09/2012
Due date:
10/10/2012
% Done:

30%

Estimated time:

Description

Hi EveryOne,

As given in http://redmine.webtoolkit.eu/projects/wt/wiki/Installing_Wt_on_MS_Windows,I have completed the downloads and while Configuring Wt using CMake,I am getting a warning message

CMake Warning (dev) at examples/feature/oauth/CMakeLists.txt:5 (TARGET_LINK_LIBRARIES):

Cannot specify link libraries for target "auth.wt" which is not built by

this project.

CMake does not support this but it used to work accidentally and is being

allowed for compatibility.

Policy CMP0016 is not set: target_link_libraries() reports error if only

argument is not a target. Run "cmake ---help-policy CMP0016" for policy

details. Use the cmake_policy command to set the policy and suppress this

warning.

This warning is for project developers. Use -Wno-dev to suppress it.

If I build the WT soln, it is throwing error as follows:

Error 57 error C2784: 'std::basic_ostream<_Elem,_Traits> &std::operator <<(std::basic_ostream<_Elem,_Traits> &,const _Elem *)' : could not deduce template argument for 'std::basic_ostream<_Elem,_Traits> &' from 'boost::detail::do_not_construct_out_stream_t' D:\projects\JWGP\Wargames\04_implementation\lib\OpenSource\boost_1_51_0\boost\lexical_cast.hpp 1318

Plz help in this regard to clear the bug and proceed .

Thanks

Puru

#1

Updated by Koen Deforche about 8 years ago

  • Status changed from New to InProgress
  • Assignee changed from Michael Vilsker to Wim Dumon
  • Target version changed from 3.2.2-p1 to 3.2.3
#2

Updated by Wim Dumon about 8 years ago

  • Status changed from InProgress to Feedback

Cannot reproduce - I suspect this has to do with bad compiler settings. Also we'd need more contextual error information.

Wim.

#3

Updated by Koen Deforche almost 8 years ago

  • Target version changed from 3.2.3 to 3.3.0
#4

Updated by Wim Dumon almost 8 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF