Project

General

Profile

Bug #1460

WDialog "finished" listeners are called twice

Added by Jan Goyvaerts about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
10/09/2012
Due date:
% Done:

0%

Estimated time:

Description

Example of adding a finished listener to a dialog:

final ItemsDialog dialog = new ItemsDialog();

dialog.show();

dialog.finished().addListener(Filters.this, new Signal1.Listener() {

@Override

public void trigger(final DialogCode code) {

if (code == DialogCode.Accepted) syncItemModel();

}

});

And the handler closing the dialog:

okButton.clicked().addListener(this, new Signal.Listener() {

@Override

public void trigger() {

done(DialogCode.Accepted);

Filters.this.remove();

}

});

Apparently when doing it this way the listeners are being called twice.

#1

Updated by Koen Deforche about 9 years ago

  • Status changed from New to Feedback
  • Assignee set to Koen Deforche
  • Target version set to 3.2.3

Hey Jan,

We cannot reproduce this. Can you reproduce this in a test-case ?

Regards,

koen

#2

Updated by Koen Deforche about 9 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF