Project

General

Profile

Bug #1485

Layouts bug

Added by Peter K almost 10 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
10/18/2012
Due date:
% Done:

0%

Estimated time:

Description

Hi Koen,

You indicated that the bug from [[[http://redmine.webtoolkit.eu/boards/2/topics/5017#message-5175]]] is fixed, but I still see the same behavior in the latest Wt git, as well as Wt-3.2.3rc ... Could you revisit it please?

#1

Updated by Koen Deforche almost 10 years ago

  • Status changed from New to Feedback

Hey,

That's odd. I double checked and this really works (with latest git, at least, but I expect the same for the 3.2.3 RC). Can you double check that you are building against the correct Wt version ?

Regards,

koen

#2

Updated by Peter K almost 10 years ago

That's odd indeed! I cloned the Wt git repository again, re-built it, checked that I am linking against the correct version of libraries, but the problem is still there. Can it specific to Windows builds?

Here's the test case that fails on my machine:

@MyApplication::MyApplication(const WEnvironment& env):

WApplication(env)

{

//Horizontal layout for root() with two WContainerWidgets

WHBoxLayout* mainLayout=new WHBoxLayout(root());

WContainerWidget* leftContainer=new WContainerWidget();

WContainerWidget* rightContainer=new WContainerWidget();

mainLayout->addWidget(leftContainer);

mainLayout->addWidget(rightContainer);

mainLayout->setStretchFactor(rightContainer,1); //right WContainerWidget is stretched

rightContainer->addWidget(new WText("RIGHT_CONTENT"));

//Left WContainerWidget has two other WContainerWidgets as children

//The top child has a layout, the bottom one is empty

WContainerWidget* leftTopContainer=new WContainerWidget(leftContainer);

WHBoxLayout* leftTopLayout=new WHBoxLayout(leftTopContainer);

WText* titleText=new WText("LEFT_CONTENT",leftTopContainer);

leftTopLayout->addWidget(titleText);

WContainerWidget* leftBottomContainer=new WContainerWidget(leftContainer);

}@

Thanks,

Peter

#3

Updated by Koen Deforche over 9 years ago

  • Status changed from Feedback to InProgress
  • Assignee set to Koen Deforche
  • Target version set to 3.3.1

I've got a change staged for 3.3.1 that will make this test case work --- but a workaround is to make sure you have an uninterrupted chain of layouts

#4

Updated by Koen Deforche about 9 years ago

  • Status changed from InProgress to Resolved
#5

Updated by Koen Deforche about 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF