Project

General

Profile

Bug #1507

default_token is not a static member of class boost::random::random_device

Added by Anonymous almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
11/23/2011
Due date:
% Done:

0%

Estimated time:

Description

wt-3.1.11\src\web\random_device.cpp:125: error: 'const char* const boost::random::random_device::default_token' is not a static member of 'class boost::random::random_device'

wt-3.1.11\src\web\random_device.cpp: In constructor 'boost::random::random_device::random_device(const std::string&)':wt-3.1.11\src\web\random_device.cpp:165: error: 'max_value' was not declared in this scope

This is against Boost 1.48 and Wt 3.1.11

On Win64, using mingw32, cmd prompt.

/root/wt-3.2.2-p1/src/web/random_device.cpp:48: error: 'const unsigned int boost::random::random_device::min_value' is not a static member of 'class boost::random::random_device'

/root/wt-3.2.2-p1/src/web/random_device.cpp:48: error: uninitialized const 'boost::random::random_device::min_value'

/root/wt-3.2.2-p1/src/web/random_device.cpp:49: error: 'const unsigned int boost::random::random_device::max_value' is not a static member of 'class boost::random::random_device'

/root/wt-3.2.2-p1/src/web/random_device.cpp:49: error: uninitialized const 'boost::random::random_device::max_value'

/root/wt-3.2.2-p1/src/web/random_device.cpp:54: error: 'const char* const boost::random::random_device::default_token' is not a static member of 'class boost::random::random_device'

/root/wt-3.2.2-p1/src/web/random_device.cpp: In constructor 'boost::random::random_device::random_device(const std::string&)':

/root/wt-3.2.2-p1/src/web/random_device.cpp:165: error: 'max_value' was not declared in this scope

make[2]: * [src/CMakeFiles/wt.dir/web/random_device.o] Error 1

make[1]: * [src/CMakeFiles/wt.dir/all] Error 2

Fedora, clean new install, newest boost compiled from source

#1

Updated by Peter K almost 8 years ago

Yep, I've seen this before. It's not a bug, it's a configuration problem. To fix it, uncheck the "WT_NO_BOOST_RANDOM" check box in the CMake configuration list. I believe that should do the trick.

Question to the WT developers: would it make sense to have this option off by default?

#2

Updated by Koen Deforche almost 8 years ago

  • Status changed from New to InProgress
  • Assignee set to Wim Dumon
#3

Updated by Wim Dumon almost 8 years ago

  • Status changed from InProgress to Resolved

Peter,

It's intended to set itself to the correct value, but the auto-detection may fail on some particular boost versions.

Wim.

#4

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed
  • Target version set to 3.3.0

Also available in: Atom PDF