Project

General

Profile

Bug #1521

wt 3.2.3 WVBoxLayout issue

Added by Stefan Ruppert almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
11/13/2012
Due date:
% Done:

0%

Estimated time:

Description

Hi,

another layout issue I encountered within the WVBoxLayout implementation. I have several rows using a WVBoxLayout. The last vbox row is resizeable. If I hide the containing widget in the last vbox row, the widget is hidden and the additional space is correctly setup to the vbox row with a stretch factor.

But if I change to height of the last vbox row by dragging the appropriate border. A following hide of the containing widget screws up the layout.

Attached you will find the test application which reproduces this problem. Hit apply to hide/show the widget of the last vbox row.


Files

TestApp.cc (11.7 KB) TestApp.cc Stefan Ruppert, 11/13/2012 10:16 PM
Wt-WVBoxLayout.png (19 KB) Wt-WVBoxLayout.png Main layout Stefan Ruppert, 11/13/2012 10:23 PM
Wt-WVBoxLayout-ok.png (17.9 KB) Wt-WVBoxLayout-ok.png Layout with hidden last widget which looks ok (no resize of the last vbox row) Stefan Ruppert, 11/13/2012 10:23 PM
Wt-WVBoxLayout-wrong.png (19.1 KB) Wt-WVBoxLayout-wrong.png Layout with hidden last widget which is wrong (after a resize of the last vbox row) Stefan Ruppert, 11/13/2012 10:23 PM
#2

Updated by Koen Deforche almost 8 years ago

  • Status changed from New to Resolved
  • Assignee set to Koen Deforche

Hey Stefan,

I've made progress on fixing this issue: it works for your test case but I believe the problem isn't yet solved in its most general case (where resize handles become irrelevant when certain widgets are being hidden).

Nevertheless, I'm going to commit this already to git some time later today or tomorrow, since it certainly is no step backwards either.

Regards,

koen

#3

Updated by Peter K almost 8 years ago

Hi Koen,

Somewhat off topic, but could WHBoxLayout have the same issue? I saw some incorrect horizontal layout behavior that's similar to the problem described here. If it's related, you might kill two bugs with one stone, so to speak!

Thanks,

Peter

#4

Updated by Koen Deforche almost 8 years ago

Hey Peter,

Yes, this is entirely symmetrical and the same code, so it could be solved too (although as I said, I didn't really solve it yet in its most general case).

I still haven't pushed my changes to the public git but will do so by the end of the week !

Regards,

koen

#5

Updated by Stefan Ruppert almost 8 years ago

Hi Koen,

I still haven't pushed my changes to the public git but will do so by the end of the week !

Can you push these changes to the public git repo? I want to test your fix.

Regards,

Stefan

#6

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed
  • Target version set to 3.3.0

Also available in: Atom PDF