Project

General

Profile

Bug #1669

WDatePicker

Added by Derek Spenser over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
02/03/2013
Due date:
% Done:

0%

Estimated time:

Description

After building from the latest git, WDatePicker exhibits a couple of errors.

When WDatePicker parent is WDialog contents, WDatePicker will not populate date string into lineedit from calendar selection. Error message shows:

[2013-Feb-02 19:05:53.692335] 1913 [/ WJAnqbMsGKy4FEUR] [error] "Wt: decodeSignal(): signal 's57' not exposed".

This only occurs when the widget is contained within WDialog's contents. When widget's parent is other WContainerWidget, the WDatePicker performs as expected.

To reproduce this issue, set WDatePicker's parent to WDialog's conents, click calendar icon which shows calendar, click any calendar date.

Code Example:

WDialog d;

WDatePicker(d.contents());

Also, another error is logged but does not seem to hinder any functionality. When WDatePicker's icon is clicked, the following errors are logged:

[2013-Feb-02 19:07:50.943959] 1951 [/ w9RZC7hQgIVTSyBk] [error] "WEvent: Could not cast event property 'scrollX: undefined' to int"

[2013-Feb-02 19:07:50.944008] 1951 [/ w9RZC7hQgIVTSyBk] [error] "WEvent: Could not cast event property 'scrollY: undefined' to int"

[2013-Feb-02 19:07:50.944046] 1951 [/ w9RZC7hQgIVTSyBk] [error] "WEvent: Could not cast event property 'width: undefined' to int"

[2013-Feb-02 19:07:50.944077] 1951 [/ w9RZC7hQgIVTSyBk] [error] "WEvent: Could not cast event property 'height: undefined' to int"

To reproduce this issue, create WDatePicker and click on calendar icon.

#1

Updated by Koen Deforche over 7 years ago

  • Status changed from New to Resolved

Hey,

I believe I have noticed and fixed exactly the same problems with the last update to git. Can you confirm it also solves it for you ?

Regards,

koen

#2

Updated by Derek Spenser over 7 years ago

Confirmed. This is fixed. I did however notice the close button is gone from the calendar. This is not a problem, the calendar can still be closed by clicking the calendar icon or outside the calendar, so the functionality is still available, I just noticed the close button was gone. Was this intentional?

#3

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Koen Deforche
  • Target version set to 3.3.0

Yes, removing the close button was intentional, since it is now implicit as you click outside of it. It seems a more common and simple approach to this kind of popup widget ?

Regards,

koen

Also available in: Atom PDF