Project

General

Profile

Feature #1728

Support of disabled item within WComboBox

Added by Stefan Ruppert over 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
03/01/2013
Due date:
% Done:

0%

Estimated time:

Description

Hi,

I would like to have a setItemDisabled(int index, bool disable) method within WComboBox class. Thus an user cannot select such a disabled item from the WComboBox. The attached screenshot is from a Trac Custom Search page which shows this feature.

To implement this I would add a Wt::ItemFlag::ItemIsDisabled and add support for it within the WStringListModel (maybe a member std::vector disabled_?). Within the WComboBox class the updateDom() method should then set the PropertyDisabled if the item is disabled.

Regards,

Stefan


Files

ComboBox-Disabled.png (11.2 KB) ComboBox-Disabled.png Trac Custom Search disabled ComboBox item example Stefan Ruppert, 03/01/2013 07:07 AM
#1

Updated by Jan HrubeŇ° over 9 years ago

Hi,

this is duplicate of feature #1179 .

I'm using a java script workaround for now. It is mentioned in #1179 post.

regards,

Jan

#2

Updated by Koen Deforche over 9 years ago

  • Status changed from New to InProgress
  • Assignee set to Koen Deforche
#3

Updated by Koen Deforche about 9 years ago

  • Status changed from InProgress to Resolved
#4

Updated by Koen Deforche about 9 years ago

Fixed using the ItemIsSelectable flag (and adding setFlags() to WStringListModel)

#5

Updated by Koen Deforche about 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF