Project

General

Profile

Bug #1752

WT with GetProcAddress

Added by Anonymous over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Target version:
-
Start date:
03/19/2013
Due date:
% Done:

0%

Estimated time:

Description

Hello,

There is one application 'A' using WT. I want to use one function 'F' from dll which loads via GetProcAddress.

The function can be called but after calling, process cannot return WT side.

function MA in A -> LoadLibrary -> calling F via GetProcAddress -> F works

-> A is stopped. (It should have been returned MA)

F is just simple function to print 'Hello' message.

Do you have any idea about this issue?


Files

dll_Folder.zip (2.01 MB) dll_Folder.zip dll application Richard Moon, 03/20/2013 12:24 AM
app_hello.zip (4.97 MB) app_hello.zip main application from wt example Richard Moon, 03/20/2013 12:24 AM
#1

Updated by Koen Deforche over 9 years ago

  • Status changed from New to InProgress
  • Assignee set to Wim Dumon
#2

Updated by Wim Dumon over 9 years ago

Hi,

No, Wt does not interfere with any of this. Maybe it's a problem with MSVC runtime libraries that are incompatible?

Do you see anything special in the stack trace of the 'stopped' wt process?

BR,

Wim.

#3

Updated by Wim Dumon over 9 years ago

  • Status changed from InProgress to Feedback
#4

Updated by Richard Moon over 9 years ago

Hi,

I update my projects - dll and main applications.

#5

Updated by Wim Dumon over 9 years ago

  • Status changed from Feedback to Closed

This turned out to be caused by bad DLLs in the project (old build?).

Also available in: Atom PDF