Project

General

Profile

Bug #1811

WColor transparancy

Added by Стойчо Стефанов Stoycho Stefanov over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
04/03/2013
Due date:
% Done:

0%

Estimated time:

Description

Hey,

in Wt-3.3.0 seems the WColor transparency not to be supported, i.e., if the alpha component is in (0,255) (an open interval) the rendered colour is black.

Regards,

Stoycho


Files

Panel_transparancy.zip (27.8 KB) Panel_transparancy.zip test case for the colour transparancy (only Shape.cpp is modified) Стойчо Стефанов Stoycho Stefanov, 04/03/2013 09:22 AM
#1

Updated by Koen Deforche over 7 years ago

  • Status changed from New to InProgress
#2

Updated by Koen Deforche over 7 years ago

  • Status changed from InProgress to Resolved

Hey,

It was a CSS float encoding issue (yes, even that is weird in CSS!).

It's been fixed in latest git.

koen

#4

Updated by Стойчо Стефанов Stoycho Stefanov over 7 years ago

Hey,

could you check whether transparency is supported by WBorder as well. It does not seem to be. I could provide a test case later if needed.

Regards,

Stoycho

#5

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed
#6

Updated by Koen Deforche over 7 years ago

Hey,

This was caused by the same problem, and should be resolved now too.

Regards,

koen

Also available in: Atom PDF