Project

General

Profile

Bug #1823

WDialog fails with latest git

Added by Anonymous over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
04/08/2013
Due date:
% Done:

0%

Estimated time:

Description

If I try to create a WDialog with this code (even before calling exec(), just by creating the object):

WDialog *dialog_ = new WDialog("Hi there") ;

The result is an error from the browser (Chrome) with this text:

Wt internal error: TypeError: Cannot set property 'wtResize' of undefined, code: undefined, description: undefined

With WMessageBox:

StandardButton result = WMessageBox::show("Confirm", "About to wreak havoc... Continue ?", Ok | Cancel);

I get this:

error on line 4 at column 293: xmlParseEntityRef: no name

#1

Updated by Miguel Revilla over 7 years ago

BTW, same thing happens with AuthWidget own dialogs (Register and Forgot Password).

#2

Updated by Koen Deforche over 7 years ago

  • Status changed from New to Feedback
  • Assignee set to Koen Deforche
  • Target version set to 3.3.0

Hey,

I can't reproduce this ...

From your description it sounds that any dialog or messagebox should fail, yet it works for all examples I tried...

To make sure that we are seeing different things, if you run the hangman example, treeview-dragdrop or the widget gallery examples, you see this problem ?

Regards,

koen

#3

Updated by Miguel Revilla over 7 years ago

Hi,

The hangman example was failing too for me so after some try and error I finally solved it. I had a "contaminated" wt_config.xml from the previous version of Wt that was making dialogs fail. Everything works like a charm now. Sorry for this and please mark the bug as invalid.

Thanks for your help

#4

Updated by Koen Deforche over 7 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF