Project

General

Profile

Bug #2008

After WApplication::setLocale("en") there is a error on browser window "TypeError: c is undefined"

Added by Łukasz Matuszewski over 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
-
Start date:
07/04/2013
Due date:
% Done:

0%

Estimated time:

Description

I just do WApplication::setLocale("en") or WApplication::setLocale("pl") in my code and bug remains.

To show it live go to https://synat.eti.pg.gda.pl/wt/SyNaTPG.wt with newest Firefox and try

to change locale by clicking on flag on the right top side of screen.


Files

SyNaTPG2NewTest.zip (2.08 MB) SyNaTPG2NewTest.zip Łukasz Matuszewski, 08/29/2013 09:54 PM
SyNaTPG2NewTest2.zip (2.3 MB) SyNaTPG2NewTest2.zip Łukasz Matuszewski, 09/27/2013 03:21 PM
SyNaTPG.wt.zip (3.9 MB) SyNaTPG.wt.zip Łukasz Matuszewski, 09/27/2013 03:21 PM
TypeError_c_is_undefined.png (316 KB) TypeError_c_is_undefined.png Łukasz Matuszewski, 09/27/2013 03:21 PM
#1

Updated by Łukasz Matuszewski over 8 years ago

Actually a blocked the WApplication::setLocale(...) emitted by flag button. If you need more feedback the write it here i will answer, but be quick i am going to my vacation from 9.7.2013 to 7.8.2013.

#2

Updated by Wim Dumon over 8 years ago

Lukasz,

I didn't see it working. Any chance you could provide us with a small test case that demonstrates the bug?

BR,

Wim.

#3

Updated by Koen Deforche over 8 years ago

  • Status changed from New to InProgress
  • Assignee set to Wim Dumon
#4

Updated by Łukasz Matuszewski over 8 years ago

Test case included. You will want to modify CMakeLists.txt to compile it (how_to_build.txt) eg. include GraphicsMagic and LIBHARU libraries if those was compiled with wt.

Steps to reproduce the bug:

1. Run the demo.

  1. Go to http://localhost/wt/SyNaTPG.wt (if this was your app url).
  2. Click on "Genre recognition" menu item
  3. Click on "Menu explorer" ... where you can find a table with item delegate (then try to set locale to polish/english multiple times to see this js error).

Hopy it helps.

BR

Luke

#5

Updated by Koen Deforche about 8 years ago

  • Status changed from InProgress to Feedback
  • Assignee changed from Wim Dumon to Koen Deforche

Hey,

Thanks for the test case. I am trying to reproduce this but apparently something is wrong. The 'Menu Explorer' tab is empty; 'Genre Recognition' simply contains the phrase 'genre recognit' and whatever I do I can't see the table.

I verified that everything seems to be deployed correctly since there are no 404 errors. Also swithcing languages seems to work just fine without javascript error.

Regards,

koen

#6

Updated by Łukasz Matuszewski about 8 years ago

Hey,

You can now run the program by extracting it from SyNaTPG.wt.zip (but there will be some not translated messages on menu).

You can run it with such command line:

SyNaTPG.wt.exe ---docroot path_to_/var/www_in_SyNaTPG2NewTest2.zip_archive ---deploy-path /wt/SyNaTPG.wt ---http-address 0.0.0.0 ---http-port 8080 -c path_to_wt_config.xml_in_SyNaTPG2NewTest2.zip_archive

The source is also included in SyNaTPG2NeTest2.zip (i changed the default menu item selected first).

The bug can be seen by selecting Menu explorer (Strona główna) and then trying to change the language (by buttons on right top screen edge .. they have flags of Poland and Great Britain). In Firefox i saw this error in WWW Console (Console WWW) ... as in screenshot.

#7

Updated by Benoit Daccache over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF