Project

General

Profile

Bug #2394

Heavy updating of WTableView objects leads to JavaScript error

Added by Anonymous over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
11/05/2013
Due date:
% Done:

0%

Estimated time:

Description

Hello,

in my applications WTableView is used a lot to display business data. According to user input, the model data for a WTableView object is cleared and refilled with new data. This leads to a redraw of the WTableView object. During this redraw, I am getting JavaScript errors, saying that some object does not exist. The JavaScript errors are not reproduceable, but seem to be more likey on faster machines with IE 9 / 10.

I have caught one of these exceptions (see attachment). Here object j452, which should reference "oi0xfro", is null at this assignment "j452.innerHTML='';". Indeed "oi0xfro" is defined further down in the script. So the sequence of the JavaScript statements seems to be messed up.


Files

wt_js_block.txt (19.3 KB) wt_js_block.txt Anonymous, 11/05/2013 03:49 PM
wt_app_screenshot.png (168 KB) wt_app_screenshot.png Alexander Schnellberger, 11/06/2013 12:07 PM
#1

Updated by Koen Deforche over 8 years ago

  • Status changed from New to Feedback

Hey,

What version of Wt is this? Are you using server-push (WApplication::enableUpdates()) in any way?

Regards,

koen

#2

Updated by Alexander Schnellberger over 8 years ago

Hi Koen,

sorry I forget to mention this: I am using Wt 3.3.0 and server-push.

Best regards,

Alex

#3

Updated by Koen Deforche over 8 years ago

  • Assignee set to Koen Deforche
  • Target version set to 3.3.0

Hey,

It looks like you also recreate the WTableView? Some more information on the code involved would be great. And it would also be informative whether the problem still exists in Wt 3.3.1.

Regards,

koen

#4

Updated by Alexander Schnellberger over 8 years ago

Hello Koen,

I am not recreating a WTableView, when the contents is refilled. But I am using several WTableView's at the same time and a new WTableView may be created at any point in time due to user interaction. The attached screenshot might be helpfull to understand, what I am doing. You can see a list of settings at the left of the screen, where each setting box is a WTableView instance (btw: the table on the right is also a WTableView). The setting boxes are filled, when the user navigates to this screen. And this is the situation, where I get the JavaScript errors.

In my case the Wt is embedded in an existing large inhouse application development framework with its special programming language. The bytecode interpreter of this language controls the user interface, which is commonly Qt but now also Wt is a possible option. So its nearly impossible for me to provide you a reasonable small piece of code, that shows what I am doing.

As soon as I can find some time, I will try Wt 3.3.1 and let you know.

Regards,

Alex

#5

Updated by Koen Deforche over 8 years ago

Hey,

Sorry for not following up on this properly; are you still blocked on this? This looks indeed like a bug in Wt, but we'll need more insight in the circumstances in order to reproduce it.

Does it still occur with more recent Wt versions (e.g. 3.3.2rc2 ?)

Regards,

koen

#6

Updated by Koen Deforche over 7 years ago

  • Status changed from Feedback to Closed
  • Target version changed from 3.3.0 to 3.3.4

Please reopen a new ticket if this still persists.

Also available in: Atom PDF