Project

General

Profile

Bug #2747

Wt 3.3.2 rc2 produces 100% CPU usage within Firefox v27

Added by Stefan Ruppert almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
03/01/2014
Due date:
% Done:

0%

Estimated time:

Description

I just wanted to test the wt 3.3.2 rc and directly after connecting Firefox to our Wt application using http connector Firefox uses more than 100% CPU time. I also noticed that some WebRequests took around 10 seconds!?

[2014-Mar-01 16:44:52.700296] 22010 - [info] "WebRequest: took 10826.6ms"
[2014-Mar-01 16:44:53.181027] 22010 - [info] "WebRequest: took 10001.9ms"

Same thing with Chrome. It seems that some JS is running crazy...


Files

Firefox-100_-CPU-time-ok.png (94.3 KB) Firefox-100_-CPU-time-ok.png Firefox ok Stefan Ruppert, 03/02/2014 01:11 PM
Firefox-100_-CPU-time-bad.png (87.8 KB) Firefox-100_-CPU-time-bad.png Firefox uses 100% CPU Stefan Ruppert, 03/02/2014 01:11 PM
#1

Updated by Koen Deforche almost 8 years ago

  • Assignee set to Koen Deforche
  • Target version set to 3.3.2

Hey,

The 10s reported isn't accurate, we still need to clean this up.

The 100% CPU problem does sound serious. I have to guess it is related to layout, are you using layout managers in some particular way?

Does the layout come out okay? Does the application actually work are the browser just hangs?

Are you updating from 3.3.1?

Regards,

Koen

#2

Updated by Stefan Ruppert almost 8 years ago

Hi Koen,

yes we use layout managers. Mainly VBox and HBox based layouts. The layout looks good. And yes with 3.3.1 its running fine.

The application works but its really slow. Maybe this observation helps?

Our application asks for a user name as shown in the first screenshot and in this situation the 100% CPU usage does not occur and the layout of the application is already build and correct as you can see.

After applying an user name the application enters main event loop and here the 100% CPU usage will take place

Regards,

Stefan

#3

Updated by Koen Deforche almost 8 years ago

  • Status changed from New to Feedback

Hey Stefan,

Thanks for the additional information. I believe the cpu burn issue is caused by a non-converging layout (i.e. where applying the layout has an unexpected consequence of affecting it; which I could reproduce in one test-case here).

Could you check whether the last github Wt version still exhibits this issue?

Regards,

koen

#4

Updated by Stefan Ruppert almost 8 years ago

Hi Koen,

the latest fix in the git version resolves this issue.

However I noticed a slow down in using the mouse wheel within a MVC WTableView within Firefox V27. I tested this slow down with wt 3.2.3, wt 3.3.1 and wt 3.3.-rc2 and in all these versions the slow down occurs.

I tested it with Chrome Version 28.0.1500.52 and the scrolling is pretty fast. So it seems to me that something is wrong with Wt in conjunction with Firefox V27 I'll file a new bug.

Regards,

Stefan

#5

Updated by Koen Deforche almost 8 years ago

  • Status changed from Feedback to Resolved
#6

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF