Project

General

Profile

Bug #2760

Capture JavaScript error server-side

Added by Koen Deforche over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Michael Vilsker
Target version:
Start date:
03/06/2014
Due date:
% Done:

0%

Estimated time:

Description

When now a JavaScript error occurs this is usually fatal but hard to diagnose post-mortem.

With this option we would relay all relevant information (as much as can be captured) of the problem server-side so that the cause or conditions for reproduction can be determined easily.

#1

Updated by Koen Deforche about 8 years ago

  • Target version changed from 3.3.3 to 3.3.4
#2

Updated by Koen Deforche about 8 years ago

  • Assignee changed from Koen Deforche to Michael Vilsker

See Wt.js where we catch the exception tot display an alert. We should post back all possible information with request=errorlog which then gets handled in WebSession

#3

Updated by Michael Vilsker about 8 years ago

  • Status changed from InProgress to Resolved
#4

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF