Project

General

Profile

Bug #2820

WText.h does not include TContainerWidget

Added by I. Lazaridis over 7 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/14/2014
Due date:
% Done:

0%

Estimated time:

Description

A simple application which uses just one WText and includes it via

#include <Wt/WText>

fails to compile, because WText.h does not contain

#include <Wt/WContainerWidget>
#1

Updated by Koen Deforche over 7 years ago

  • Status changed from New to Rejected
  • Assignee set to Koen Deforche

Thanks for reviewing our header files.

With what compiler are you seeing this problem? It seems though that you and/or the compiler isn't aware of the concept of C forward declarations?

$ cat troll.cc 
#include <Wt/WText>
$ g++ -c troll.cc -o troll.o
$
#2

Updated by I. Lazaridis over 7 years ago

Koen Deforche wrote:

Thanks for reviewing our header files.

With what compiler are you seeing this problem? It seems though that you and/or the compiler isn't aware of the concept of C forward declarations?

I'm just creating a simple hello-world app, which does not compile on MSVC2012

https://github.com/lazaridis-com/wt-starter/blob/master/1-hello/hello.C

The problem is finally not with WText, but with WApplication (and its not "TContainerWidget" but "WContainerWidget").

Neither the forward declarations, nor your completeley unprofessionall "troll" nonsense have any relevance to this existente issue.

#include - should be enough to use WApplication in the code (including the root()->addWidget(), which fails).

#3

Updated by I. Lazaridis over 7 years ago

See #2822

Also available in: Atom PDF