Project

General

Profile

Bug #2928

Access violation error when deleting a WFileResource which is assigned to WMediaPlayer

Added by Eddy Peeters about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
04/10/2014
Due date:
% Done:

0%

Estimated time:

Description

Version 3.3.2

_mediaPlayer = new WMediaPlayer(WMediaPlayer::Audio);

_playerfile = new WFileResource("audio/mpeg3", _fileName_1);

_mediaPlayer->addSource(WMediaPlayer::MP3, _playerfile);

// Now you can listen to file

_mediaPlayer->clearSources();

delete _playerfile;

_playerfile = new WFileResource("audio/mpeg3", _fileName_2);

_mediaPlayer->addSource(WMediaPlayer::MP3, _playerfile);

When deleting WFileResource ---> Error: Unhandled exception: 0xC0000005: Access violation reading location 0x0000000000000000.

This construction was working in version 3.3.1

When WFileResource is not deleted, it works but I have a memory leak.

#1

Updated by Wim Dumon about 8 years ago

Hello Eddy,

Can you also post the stack trace?

BR,

Wim.

#2

Updated by Koen Deforche about 8 years ago

  • Status changed from New to Resolved
  • Assignee set to Koen Deforche
  • Target version set to 3.3.3

This is a duplicate of #2821

#3

Updated by Koen Deforche about 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF