Project

General

Profile

Bug #3063

websocket stability

Added by mat Sch over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Immediate
Assignee:
Target version:
Start date:
05/05/2014
Due date:
% Done:

0%

Estimated time:

Description

My WT application sends frequent javascript messages to the client using doJavaScript. They're small massages but there can be 10-20 per second. This usually works great however about once every 15 minutes I see at least one issue. I've tried both wt 3.3.2 and a git snapshot from 4/29/2014 and I'm seeing the same issues.

#1 observed behavior is data sent from Wt server never reaches the webpage. Logs report "discarding broken asyncResponse, (ws: 1". If i change WebSession.C::2168 to "if (!asyncResponse_ || (pollRequestsIgnored_ == 10)) {" then the issue goes away and I believe messages are arriving normally.

#2 about once every three hours I see "wthttp: WtReply::send() called while still busy sending..."(Latest snapshot from git has a different message), followed by "Wt: session destroyed (#sessions = 0)". After that the application instance is dead.

I've grouped these two issues into 1 because i'm not sure if they're related.

Thanks

#1

Updated by mat Sch over 7 years ago

I've observed this behavior in chrome and firefox.

#2

Updated by Koen Deforche over 7 years ago

  • Status changed from New to Feedback
  • Assignee set to Koen Deforche

Hey,

For us to reproduce these issues, can you provide a test case?

It sounds like at some point the browser got an error on the WebSockets link, which is unexpected. Is this in a local setup or could be a proxy involved?

The second issue seems to indicate that actually the application exists for another reason. Do you see any other exception (prior to this error message) logged?

Regards,

koen

#3

Updated by Koen Deforche over 7 years ago

  • Target version changed from 3.3.3 to 3.3.4
#4

Updated by Koen Deforche over 6 years ago

  • Status changed from Feedback to Closed

We might have fixed that with several other bug fixes; but feel free to reopen or file again if you see issues.

Also available in: Atom PDF