Project

General

Profile

Bug #307

Sizing issues with Ext::TableView

Added by Vincenzo Romano about 12 years ago. Updated about 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
02/26/2010
Due date:
% Done:

0%

Estimated time:

Description

Wt version: 3.1.1a (from repository https://launchpad.net/\~pgquiles/+archive/ppa)

ExtJS version: 3.1.1

OS: Ubuntu Linux 9.10 (Karmic)

Browser: Google Chrome 5.0.307.9 beta

Browser: Mozilla Firefox 3.58

Browser: Konqueror 4.4.00 (KDE 4.4.0)

The Ext::TableView needs to be created and displayed after the button is clicked.

What Happens is that the widget is displayed in a weird way and gets its expected appearance only if the page is re-painted.

For example,click on the browser window icon to de-maximize (not the minimize one) or just wait for 5 minutes, when there will be a js triggered "ping and refresh" event.

If, instead, the creation code is not tied to the button event, then the TableView is displayed in the expected way.

(Check comments at line no.68)


Files

Main.cpp (2.81 KB) Main.cpp The main source code fragment Vincenzo Romano, 02/26/2010 03:37 PM
acss.css (486 Bytes) acss.css The CSS (not really important) Vincenzo Romano, 02/26/2010 03:37 PM
konqueror-1.png (28.2 KB) konqueror-1.png Output before clicking the button (Konqueror) Vincenzo Romano, 02/26/2010 03:37 PM
konqueror-2.png (34.9 KB) konqueror-2.png Output after clicking on the button Vincenzo Romano, 02/26/2010 03:37 PM
konqueror-3.png (52.3 KB) konqueror-3.png Output after clicking on the de-maximize button Vincenzo Romano, 02/26/2010 03:37 PM
#1

Updated by Koen Deforche about 12 years ago

  • Status changed from New to Closed
  • Assignee set to Koen Deforche

Fixed in latest git. The issue was caused by the deferred JavaScript execution waiting on the ExtJS libraries to be loaded.

Also available in: Atom PDF