Project

General

Profile

Bug #3214

Wt's http server endless loop of GET requests

Added by Saif Rehman over 7 years ago. Updated over 7 years ago.

Status:
InProgress
Priority:
High
Assignee:
Target version:
-
Start date:
05/26/2014
Due date:
% Done:

0%

Estimated time:

Description

How to reproduce:

  1. In wt_config.xml set Auto
  2. Run any example application
  3. Access the application through your web browser

The browser keeps reloading and the console shows endless GET requests until you stop the browser

I believe its because bootstrap redirects with the GET parameter 'request'=script and that request is treated as a dead session.

[2014-May-26 19:30:19.934993] 732 - [success] "Server successfully started! Time taken to start: 747 MS"
127.0.0.1 - - [2014-May-26 19:30:33.213753] "GET / HTTP/1.1" 404 85
127.0.0.1 - - [2014-May-26 19:30:39.296101] "GET /wt HTTP/1.1" 200 4387
127.0.0.1 - - [2014-May-26 19:30:39.437109] "GET /wt?wtd=DTEJ4GfiJDG2rSFy&request=style HTTP/1.1" 200 39
127.0.0.1 - - [2014-May-26 19:30:39.437109] "GET /wt?wtd=DTEJ4GfiJDG2rSFy&sid=1910117880&tz=300&htmlHistory=true&deployPath=%2Fwt&request=script&rand=3898643001 HTTP/1.1" 200 66
127.0.0.1 - - [2014-May-26 19:30:39.485111] "GET /wt HTTP/1.1" 200 4387
127.0.0.1 - - [2014-May-26 19:30:39.553115] "GET /wt?wtd=mmyZRgks1mEhgRVO&request=style HTTP/1.1" 200 39
127.0.0.1 - - [2014-May-26 19:30:39.592118] "GET /wt?wtd=mmyZRgks1mEhgRVO&sid=-285107186&tz=300&htmlHistory=true&deployPath=%2Fwt&request=script&rand=4276372390 HTTP/1.1" 200 66
127.0.0.1 - - [2014-May-26 19:30:39.611119] "GET /wt HTTP/1.1" 200 4386
127.0.0.1 - - [2014-May-26 19:30:39.677122] "GET /wt?wtd=dlHONoMOhs7LWaXr&request=style HTTP/1.1" 200 39
127.0.0.1 - - [2014-May-26 19:30:39.692123] "GET /wt?wtd=dlHONoMOhs7LWaXr&sid=252486945&tz=300&htmlHistory=true&deployPath=%2Fwt&request=script&rand=3131185299 HTTP/1.1" 200 66
...
...
...

I also attached my config file

#1

Updated by Koen Deforche over 7 years ago

  • Status changed from New to InProgress
  • Assignee set to Koen Deforche
#2

Updated by Koen Deforche over 7 years ago

  • Status changed from InProgress to Feedback

Hey,

I can't reproduce this with current git (~ wt 3.3.3RC1). I tried running hello.wt with the following wt_config.xml. What versino of Wt do you see this with?

Regards,

koen

<server>
    <application-settings location="*">
        <session-management>
            <tracking>Auto</tracking>
            <reload-is-new-session>false</reload-is-new-session> <!-- enabling or disabling this also works properly -->
        </session-management>
    </application-settings>
</server>
#3

Updated by Saif Rehman over 7 years ago

I checked again, it works fine on Release mode, however on RelWithDebInfo C doesn't stop(maybe its not assert checking) however on Debug mode, debug assertion failed window shows up.

#5

Updated by Koen Deforche over 7 years ago

  • Assignee changed from Koen Deforche to Wim Dumon

Hey,

So it's something you experience on MSVC?

Wim, can we reproduce this?

Regards,

koen

#6

Updated by Saif Rehman over 7 years ago

The debug did go through win_iocp, a boost file so I guess it has to do with Windows.

#7

Updated by Wim Dumon over 7 years ago

  • Status changed from Feedback to Resolved

I could reproduce this and fixed it (will be in public git soon). Thank you for reporting!

BR,

Wim.

#8

Updated by Saif Rehman over 7 years ago

I tried the latest git version. Although the web pages doesn't hang now but POST requests are being flooded now.

#9

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to InProgress

Also available in: Atom PDF