Project

General

Profile

Bug #3418

WInPlaceEdit without buttons only gets focus every second click

Added by Stefan Ruppert almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
07/02/2014
Due date:
% Done:

0%

Estimated time:

Description

Hi,

when I use a WInPlaceEdit widget and disable the Cancel and Save Buttons using setButtonsEnabled(false) and clicking on the inplace edit only each second click has an active focus of the WLineEdit widget. With buttons enabled the focus is always set correctly. This bug is annoying since you need to click twice to be able to enter some text...

Also it would be nice to have an contructor which can disable the buttons on construction!

Regards,

Stefan

#1

Updated by Stefan Ruppert almost 8 years ago

Seems to be a Firefox problem. Tested with v29 and v30.

With Chrome it works fine!

Stefan

#2

Updated by Koen Deforche over 7 years ago

  • Status changed from New to InProgress
  • Assignee set to Koen Deforche
  • Target version set to 3.3.4
#3

Updated by Koen Deforche over 7 years ago

  • Status changed from InProgress to Feedback

Hey,

I have not been able to reproduce this with Firefox 30 on either Linux or Windows.

Perhaps it's been fixed indirectly somehow. Could you check if latest git works correctly?

Koen

#4

Updated by Stefan Ruppert over 7 years ago

Hi Koen,

it seems that it was an issue with Firefox under LinuxMint 14. I upgraded to latest LinuxMint 17 and it works fine even with Wt 3.3.2!

What about adding a Ctor which disables the buttons by default?

Stefan

#5

Updated by Koen Deforche over 7 years ago

  • Status changed from Feedback to Resolved

Hey,

I've followed you on the constructor suggestion.

Koen

#6

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF