Project

General

Profile

Bug #3498

WSelectionBox regression in 3.3.3

Added by Martin Dyring-Andersen almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
07/21/2014
Due date:
% Done:

0%

Estimated time:

Description

Hello,

Pre-selecting (multiple) items in a WSelectionBox seems to be broken in 3.3.3 (can be verified by looking at widget gallery on webtoolkit.eu).

Tested in 3.3.2 and 3.3.1 where it works as expected, so it seems to be a bug introduced in 3.3.3.

See this forum thread: http://redmine.emweb.be/boards/2/topics/9365?r=9373

BR,

Martin

#1

Updated by Wim Dumon almost 8 years ago

  • Status changed from New to Feedback

Hi Martin,

The deployed widget gallery works for me (tested on Windows with FF and Chrome). Holding the ctrl or shift key while clicking the pizza toppings selects multiple items.

What browser do you use?

Wim.

#2

Updated by Martin Dyring-Andersen almost 8 years ago

Hi Wim,

I tried IE 11 and Opera 23. But the problem is not selecting items manually, that works just fine.

It is the pre-selection if items that does not work. If you look at the example code, it is supposed to select items 1 and 4 (if I recall correctly). However no items are preselected.

BR,

Martin

#3

Updated by Koen Deforche almost 8 years ago

  • Status changed from Feedback to Resolved
  • Target version set to 3.3.4

This has been fixed since in git.

#4

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF