Project

General

Profile

Bug #3530

3.3.3 doesn't compile on boost 1.56

Added by Sven-Hendrik Haase almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
08/15/2014
Due date:
% Done:

0%

Estimated time:

Description

I won't post any specific errors here as they are reproducible in 100% of the cases. Basically just try to compile wt on the newest boost, 1.56.


Files

boost.patch (487 Bytes) boost.patch Sven-Hendrik Haase, 08/16/2014 08:16 PM
#1

Updated by Sven-Hendrik Haase almost 8 years ago

For note: git version also doesn't compile.

#2

Updated by Wim Dumon almost 8 years ago

  • Status changed from New to Feedback

What platform/compiler/error/...?

Wim.

#3

Updated by Sven-Hendrik Haase almost 8 years ago

I'm pretty sure you could reproduce the error however you'd like as it is a boost 1.56 problem. However, for the record I'm using Arch Linux and it fails on gcc 4.9.1 and clang 3.4.2.

gcc log: https://drive.google.com/open?id=0BxsvHVm7imYuZGg4N2xqOEp2QU0&authuser=0

clang log: https://drive.google.com/file/d/0BxsvHVm7imYueHM5VG9sd2hIZFE/edit?usp=sharing

This is only the first file it stops at. You would have to investigate yourself to get all the errors. This error along is 488K. Pretty sure you can reproduce this 100% of the time on any platform with any modern compiler as long as you use wt from git and boost 1.56.

Probably the problem is with phoenix 3.

#5

Updated by Rathnadhar K V almost 8 years ago

Namasthe,

I could not even compile on Boost 1.55.

I think its struck to Boost 1.53

Regards

Rathna

#6

Updated by Sven-Hendrik Haase almost 8 years ago

I made a patch.

#7

Updated by Sven-Hendrik Haase almost 8 years ago

Note about my patch: I don't think it's necessary to check against boost version as phoenix v3 has been in boost for at least 2 years so even older distros should have that. I'm not sure we need to force spirit to use it on older boost versions, though. At any rate, forcing it is trivial.

#8

Updated by Wim Dumon almost 8 years ago

  • Status changed from Feedback to Resolved

Hi,

1.56 on windows didn't need this fix to compile, that's where the first confusion came from. I added the fix with version check, thank you for the patch.

Best regards,

Wim.

#9

Updated by Boris Savelev almost 8 years ago

Hello!

I have another problem in wt/src/Wt/Json/Parser.C

it have #include <boost/spirit/home/phoenix/statement/throw.hpp>

but boost 1.56 haven't this file. fix it with:

#include <boost/phoenix/statement/throw.hpp> for boost 1.56

PS:

wt/src $ rgrep -l boost/spirit/home/phoenix/statement/throw.hpp

Wt/Dbo/SqlQueryParse.C

Wt/Json/Parser.C

#10

Updated by Wim Dumon almost 8 years ago

Hi,

Thank you for the report. I believe this was already patched in the latest git version of Wt.

Wim.

#11

Updated by Koen Deforche over 7 years ago

  • Assignee set to Wim Dumon
  • Target version set to 3.3.4
#12

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF