Project

General

Profile

Bug #3534

WMenuItem setDraggable and mouseWentUp inkompatible

Added by Florian Ransmayr almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
08/20/2014
Due date:
% Done:

0%

Estimated time:

Description

Hi there,

maybe there is a bug using a WMenuItem in combination with setDraggable and mouseWentUp signal. Both of the features are working fine if they are used separately. I want to be able to drag the items of a WMenu and at the same time have a context menu.

Maybe this is the same/similar to http://redmine.webtoolkit.eu/issues/3170. I couldn't really figure out the important changes of this bug fix ;(

I am doing something like the following code snippet

Wt::WContainerWidget *container = new Wt::WContainerWidget();

// Create a stack where the contents will be located.
Wt::WStackedWidget *contents = new Wt::WStackedWidget();

Wt::WMenu *menu = new Wt::WMenu(contents, Wt::Vertical, container);

Wt::WMenuItem *item = menu->addItem("Test", new Wt::WTextArea("Test Text"));

item->mouseWentUp().connect(...);
item->setDraggable("testmime", new Wt::WImage("resources/items-ok.gif"), true);

With this code and Wt version 3.3.1 it worked like expected. The menu items could be dragged around and they had a context menu. After switching to the current git version the drag operation is still available but the context menu stops working.

I would appreciate any help solving this issue.

Thanks in advance

Florian


Files

hello.C (2.7 KB) hello.C Florian Ransmayr, 08/26/2014 01:35 PM
#1

Updated by Florian Ransmayr almost 8 years ago

Added a minmal functional example that demonstrates this possible bug.

The WMenuItems in this WMenu should be draggable and has a right click context menu. The WMeniItems are draggable but the contex menu (MouseWentUp signal) is never emitted. If the following line is removed/commented the MouseWentUp signal is received.

menuItem->setDraggable("test", m_dragImage, true);

Thanks

Florin

#2

Updated by Florian Ransmayr almost 8 years ago

Hello out there.

Is there really nobody with any hint on that topic? This is keeping me away from upgrading to the new Wt version, that fixes some other problems which are already fixed in the newer version.

Thanks

Florian

#3

Updated by Koen Deforche almost 8 years ago

Hey,

Sorry for the delay which was caused by holidays.

We will investigate this with your provided test case.

Koen

#4

Updated by Florian Ransmayr almost 8 years ago

Hey Koen,

could you reproduce the problem? Do you need more information? For me this one is important as I can not upgrade to a newer Wt version because of this. But I guess that I am really alone with this problem. Maybe even the menu is not ment to be used like that...

Best regards

Florian

#5

Updated by Koen Deforche over 7 years ago

  • Status changed from New to Resolved
  • Assignee set to Koen Deforche
  • Target version set to 3.3.4

Hey,

Thanks for the test-case and sorry for the delay.

A fix is on its way.

Koen

#6

Updated by Florian Ransmayr over 7 years ago

Hi Koen,

that are really good news. Thank you for that message. As soon as the changes are available in the public git I will retest.

Best regards

Florian

#7

Updated by Florian Ransmayr over 7 years ago

Hi Koen,

thanks for your fix that works for me now.

Best regards

Florian

#8

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF