Project

General

Profile

Bug #3572

wt_3.3.3 failed to compile Ddo::mysqlend for supporting the newest version of MySQL

Added by Anonymous about 8 years ago. Updated almost 8 years ago.

Status:
Feedback
Priority:
Normal
Assignee:
Target version:
Start date:
09/09/2014
Due date:
% Done:

0%

Estimated time:

Description

as subject

#1

Updated by Wim Dumon about 8 years ago

  • Status changed from New to Feedback

Hi,

What version of MySQL, on what OS? Did you install myql manually or through some package?

BR,

Wim.

#2

Updated by Michael Z. about 8 years ago

MySQL version´╝Ü5.6.20_1, which is installed through homebrew package manager for MacOS (Mavericks, 10.9.4). Actually, after installation, only library of "libmysql" could not be found in the installation directory, while other libraries such as 'libmysqlclient' could be found.

#3

Updated by Wim Dumon about 8 years ago

There's only one library required, but it may have many different names depending on OS etc. Current Wt looks for one of these: mariadb libmariadb mariadbclient mysqlclient libmysql.

See cmake/WtFindMysql.txt

Set MYSQL_LIBRARY to the name that your installation is using.

Wim.

#4

Updated by Michael Z. about 8 years ago

okay, thanks, Wim. I will try it.

#5

Updated by Koen Deforche almost 8 years ago

  • Assignee set to Wim Dumon
  • Target version set to 3.3.4

Also available in: Atom PDF