Project

General

Profile

Bug #3613

WDialog has display/interaction issues without Javascript (theme dependent)

Added by Bruce Toll over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
10/01/2014
Due date:
% Done:

0%

Estimated time:

Description

With github (3.3.3-19-gad17d0b) version of Wt, WDialog and its derived classes display incorrectly and/or fail to respond to input. The issue is theme dependent and can be observed in the WidgetGallery. To reproduce:

Bootstrap3 (default) -

Visit: http://www.webtoolkit.eu/widgets/layout/dialogs and click on "Jump" button. The WMessageBox is not visible.

Bootstrap2 -

Visit: http://www.webtoolkit.eu/widgets/layout/dialogs?theme=bootstrap2 and click on "Jump" button. The WMessageBox looks fine, but clicking the cell input just refreshes the page.

Polished -

Visit: http://www.webtoolkit.eu/widgets/layout/dialogs?theme=polished and click on "Jump" button. The WMessageBox is not visible.

Default -

Visit: http://www.webtoolkit.eu/widgets/layout/dialogs?theme=default and click on "Jump" button. The WMessageBox is not visible.

The cause appears to be button-wrap related, due to a click handler that provides some additional javascript support for popups. The first attached patch just makes this click handler conditional on javascript support and appears to help with the default, polished, and Bootstrap2 cases.

The Bootstrap3 theme WMessageBox is still not visible using just the first patch. It seems that the default and polished themes use a Wt-dialog class to assist with WDialog positioning without Javascript. The Bootstrap2 theme uses a different mechanism and does not need the Wt-dialog class for positioning. But, Bootstrap3 does not appear to share this approach. As a workaround, the second patch just adds a Wt-dialog class to the Bootstrap3 dialog. I'm not sure if this is the best approach.

Both patches have only been lightly tested.

NOTE: The behavior of popup menus (without JS) is changed by the first patch - they are no longer visible. However, the popups do not appear to be functional or styled properly without the patch either. An example can be seen at: http://www.webtoolkit.eu/widgets/navigation/popup-menu.


Files

#1

Updated by Koen Deforche over 7 years ago

  • Status changed from New to InProgress
  • Assignee set to Koen Deforche
  • Target version set to 3.3.4

Hey Bruce,

I believe you're right with respect to the first point.

But I can't remember the reason for the style class, so I'll have to look into it.

Regards,

koen

#2

Updated by Koen Deforche over 7 years ago

  • Assignee changed from Koen Deforche to Korneel Dumon
#3

Updated by Korneel Dumon over 7 years ago

  • Status changed from InProgress to Resolved
#4

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF