Project

General

Profile

Bug #3695

[wt-3.3.4-rc1] WPushButtons within (modal) WDialog cannot be clicked in Firefox with disabled JavaSctript

Added by Стойчо Стефанов Stoycho Stefanov almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
12/04/2014
Due date:
% Done:

0%

Estimated time:

Description

Hey,

after wt-3.3.1 (tested for 3.3.3 and 3.3.4-rc1) I cannot click on a button in a modal WDialog when JavaScript is disabled in Firefox. Moreover the WDialog is not rendered in the middle of the browser window as in 3.3.1.

Perhaps, the problem is in the button wrap.

In IE11 and Chrome it works with the button wrapper, but the dialogue is still not centered.

I built wt with minGW for reference, but I couldn't reproduce it. Neither the positioning nor the buttons accessibility.

I'll appreciate a fix for 3.3.4 release

Best regards,

Stoycho


Files

ModalDialogNoJavaScript.png (157 KB) ModalDialogNoJavaScript.png Стойчо Стефанов Stoycho Stefanov, 12/04/2014 10:49 AM
#1

Updated by Koen Deforche almost 8 years ago

  • Status changed from New to Feedback
  • Assignee set to Korneel Dumon

Hey,

I believe we've fixed this only recently (after 3.3.4 rc1) but we will release a 3.3.4 rc2 shortly.

koen

#2

Updated by Стойчо Стефанов Stoycho Stefanov almost 8 years ago

hey,

I built wt with minGW for reference, but I couldn't reproduce it. Neither the positioning nor the buttons accessibility.

I wasn't accurate enough here. I built the latest git revision with minGW (after 3.3.4-rc1 I suppose), but the bug is reported indeed for the 3.3.4-rc1. This can explain why I couldn't reproduce it.

Stoycho

#3

Updated by Koen Deforche over 7 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Korneel Dumon to Koen Deforche
#4

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF