Project

General

Profile

Bug #3710

Wt web site hangs for several seconds during loading on Firefox + OS X

Added by Anonymous over 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
12/27/2014
Due date:
% Done:

0%

Estimated time:

Description

It takes sometimes tens of seconds until the Wt web site is rendered. When the web site is loaded, all the pages on site can be viewed without any delays. When the web site is loaded using the network profiler of Firefox, no network delays are present. This makes me think that the problems lies in the JS engine of Firefox which changed a lot AFAIK in the recent releases.

The issue is reproducible even all the add-ons are disabled. Also the simplest Wt applications suffer from this issue.

When Firefox is restarted in safe-mode (Burger menu -> ? -> Restart with Add-ons Disabled), the web site loads as expected. According to this page (http://kb.mozillazine.org/Safe_Mode), safe-mode does more than disabling the add-ons. Especially disabled JIT and hardware acceleration are notable items.

I am using Firefox 34 on OS X 10.8.5. This issue was also reproducible on previous (and maybe also on the one before that) Firefox version as well.

I can't reproduce the issue on following configurations:

  • Windows 7
  • Kubuntu 14.04 running on Virtualbox on Windows 7 as host
  • Kubuntu 12.04 running on WMware Fusion on OS X 10.8

Files

profile.json.zip (782 KB) profile.json.zip Kayra Akman, 01/01/2015 02:21 PM
profile_data_bottleneck.png (226 KB) profile_data_bottleneck.png Kayra Akman, 01/01/2015 02:21 PM
#1

Updated by Kayra Akman over 7 years ago

I experience this issue as well. I think the problem occurs when the integrated Intel graphics card is used. When the NVidia graphics card is used, I don't experience any delays.

#2

Updated by Wim Dumon over 7 years ago

  • Status changed from New to Feedback

Hello,

My first thought goes to the webgl detection that Wt does on application startup. Could you check in wt_config.xml and set webgl-detection to false to see if the problem goes away?

Best regards,

Wim.

#3

Updated by Kayra Akman over 7 years ago

Wim Dumon wrote:

Hello,

My first thought goes to the webgl detection that Wt does on application startup. Could you check in wt_config.xml and set webgl-detection to false to see if the problem goes away?

Best regards,

Wim.

<webgl-detection>false</webgl-detection>

didn't help.

I have attached a performance profiling data from Firefox. It can be loaded via Import... on the Performance pane of Firefox. It shows where most of the time is spent (see the screenshot).

#4

Updated by Koen Deforche over 7 years ago

  • Assignee set to Koen Deforche
  • Target version set to 3.3.4

That performance chart indicates there is a problem with JQuery. Unfortunately, I cannot reproduce the issue (not on my Mac either), but could you try to see if it makes a difference if you use a more recent version of JQuery using WApplication::requireJQuery()

Koen

#5

Updated by Kayra Akman over 7 years ago

I am sorry for replying so late. I don't know the reason but after either updating Firefox or Wt from git repo, I can't reproduce the issue neither. The Wt website and all examples work as expected.

#6

Updated by Benoit Daccache almost 7 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF