Project

General

Profile

Bug #4271

[wt-3.3.4] A clickable WPopupMenuItem result null after a WDialog is closed

Added by Стойчо Стефанов Stoycho Stefanov over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
06/30/2015
Due date:
% Done:

0%

Estimated time:

Description

Hey,

the result of a clickable WPopupMenuItem is always zero after a WDialog is once called and closed. I suppose there is some bug related to the z-index of the dialog or the popup menu or both, but cannot find it by myself.

I think it's an old problem an could be reproduced in 3.3.3 as well.

I will appreciate a fix because the clickable items are so useless.

Best regards,

Stoycho


Files

ClickablePopupItem.cpp (2.79 KB) ClickablePopupItem.cpp test case Стойчо Стефанов Stoycho Stefanov, 06/30/2015 09:39 AM
#1

Updated by Стойчо Стефанов Stoycho Stefanov over 7 years ago

s. of course with clickable I mean checkable :-).

#2

Updated by Koen Deforche over 7 years ago

  • Status changed from New to Resolved
  • Assignee set to Koen Deforche

This seems to be fixed already in current git.

#3

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF