Project

General

Profile

Bug #4326

Chart::WAbstractChart::setAutoLayoutEnabled() and server side font metrics

Added by denis Bertini about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
07/15/2015
Due date:
% Done:

0%

Estimated time:

Description

Hi

I tried the Chart example with the newest release Wt 3.3.4

I am facing a problem when with the example with trigger

a Wt Fatal error saying

the server side font metrics are not available !

I read in the forum that is linked to the usage of

Chart::WAbstractChart::setAutoLayoutEnabled()

which should then be commented out.

The problem is that when one comment this out the

result is degraded and for example the editing on

the table does not work !

How can i add the font metric to Wt Library ?

Thanks in advance

Denis

#1

Updated by denis Bertini about 7 years ago

HI

I linked Wt with libHaru as explained in some previous mail

in order to solve the problem with the Font Metrics .

But still the editing mode on the table view does not work properly ?

Any idea ?

Could this be linked to a CSS style problem ?

Thanks

Denis

#2

Updated by Koen Deforche about 7 years ago

  • Status changed from New to Feedback
  • Assignee set to Koen Deforche

Hey,

What version of Wt are you using? We have been making several changes to WCartesianChart in the last month, so if you were using the git version, then it may have been a problem that has been solved in the mean time.

Regards,

koen

#3

Updated by Benoit Daccache about 7 years ago

  • Status changed from Feedback to Resolved
  • Target version set to 3.3.5
#4

Updated by Koen Deforche about 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF