Project

General

Profile

Bug #4608

WCartesianCharts with tooltips receive JS error when all tooltip data removed

Added by Bruce Toll about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
12/05/2015
Due date:
% Done:

0%

Estimated time:

Description

With Wt-3.3.5-rc2, an interactive WCartesianChart with tooltips will receive a javascript error of "areaCoordsJSON is undefined" if all tooltip data is subsequently removed from the model.

NOTE: This may be the same issue referenced in issue #4607.

A test program demonstrating the issue is attached. There is also an attached patch (for review) that seems to help with this issue in limited testing.


Files

#1

Updated by Koen Deforche about 6 years ago

  • Status changed from New to InProgress
  • Assignee set to Michael Vilsker
  • Target version set to 3.3.5
#2

Updated by Koen Deforche about 6 years ago

  • Assignee changed from Michael Vilsker to Koen Deforche
#3

Updated by Koen Deforche about 6 years ago

  • Status changed from InProgress to Resolved

Spot on, Bruce.

#4

Updated by Koen Deforche over 5 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 3.3.5 to 3.3.6

Also available in: Atom PDF