Project

General

Profile

Support #4799

Hi Everyone! Can you help me with graphics?

Added by Matt Picas over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Immediate
Assignee:
Target version:
Start date:
03/09/2016
Due date:
% Done:

0%

Estimated time:

Description

Hi Everyone! My name is Matt and I'm new to witty and have been having problems with figuring out how to get an example with graphics to run. I am trying to follow the only instructions I've been able to find here: http://redmine.webtoolkit.eu/projects/wt/wiki/Installing_Wt_on_MS_Windows

I currently just reinstalled Windows Server 2012 R2, so it is a completely clean installation. I installed Microsoft Visual Studio 2012 with Update 5 as it suggested. I downloaded the boost .zip for 1.60 and extracted it to C:\boost_1_60_0 and navigated to the folder with Command Prompt and typed this command in:

bjam ---layout=versioned variant=debug,release threading=multi link=static runtime-link=shared install

It then created a separate C:\Boost folder with an include folder and a lib folder. Everything appears to have gone fine with the boost install from what I can tell, so I then installed the latest version of CMake, CMake 3.5.0 and I ran the CMake GUI and I clicked the configure button. It was able to find my boost installation without specifying the BOOST_PREFIX in the CMake GUI programs list but I set it to C:\Boost as the instructions mentioned I should and I pressed configure again and then one more time. It did complain about not finding a mspdb110.dll but the instructions said that it didn't effect anything and to proceed. The exact error for that was \"The program can't start because mspdb110.dll is missing from your computer. Try reinstalling the program to fix this problem.

The next step was to click on Wt.sln in the build folder, mine is located in C:\projects\witty\wt-3.3.5\build. It loaded up in Microsoft Visual Studio 2012 with Debug as the default and Win32 as the default selection for application building. After it initialized everything and the blue bar at the bottom said it was Ready I added the following to the ALL_Build project properties under Configuration Properties--->VC Directories:

First I added C:\boost_1_60_0 to the Include Directories box and then I added C:\Boost\lib to the Library Directories box. I did this because I saw it on youtube on a HOWTO video on installing boost and he mentioned how you needed to have that set for it to find the boost header files. That video was here: https://www.youtube.com/watch?v=5AmwIwedTCM

At this point I pressed F7 as the instructions indicated and I was able to get it to compile with 59 projects succeeded and 2 projects skipped. The next step was to right click the INSTALL project and set it as the startup project, which I did and then I was supposed to right click it and select build which I did and it succeeded as 1 project and created a directory for WT in C:\Program Files (x86)\WT.

My next step was to test if I could get an example program to work as I had done before with the hello.wt example. Following the instructions, I had to edit that projects property sheets as well. I went into the hello.wt projects property sheets and I went under Configuration Properties--->Debugging and I added the following:

Under Command Arguments I added ---http-address=0.0.0.0 ---http-port=8080 ---deploy-path=/hello ---docroot=. and under Environment I added PATH=c:/libraries/lib;c:/Boost/lib;<path to wt.dll>;<path to wthttp.dll> as the instructions indicated. An additional thing I did from an error that I had got in my previous operating system install when testing the hello.wt project was that I went to Linker--->Input and I added C:\Program Files (x86)\WT\lib\wthttpd.lib;C:\Program Files (x86)\WT\lib\wtd.lib; under Additional Dependencies so that it could find any information it needed there (which was a problem in my previous installation before I reinstalled Windows for a clean operating system)

So this is where I am at now and the most important thing for me is to get graphics to work, particularly images for .png, .jpg, et cetera. First I need to know which example project is good for testing images, first I want to get it to appear appropriately in an example project before I end up creating a project of my own. I previously tried getting Home.wt and widgetgallery.wt to work which I thought both would have images but I could only get widgetgallery.wt to actually load with no images whatsoever. This was after I tried to follow the instructions to install Graphics Magick where I downloaded the latest .zip of Graphics Magick and I extracted it to my C:\ drive. This was on my previous installation where I went into the VisualMagick/configure folder and ran configure.exe. Unfortunately it generates a solution for Microsoft Visual Studio version 7.0 which is very old and out dated, and it appears the only alternative is for it to generate a solution for the 6.0 version which is even more out dated. I did generate it as the instructions indicated by checking off Dynamic Multi Threaded DLL runtimes and Use X11 Windows in the configure.exe programs setup. After that however it says to open VisualStaticMT.sln when it generates as VisualDynamicMT because of the previous selection the instructions told me to make in the configure.exe Setup program.

I opened up that file anyway and I proceeded but when I got to compiling it 8 projects failed and I had 54 errors and I also had over 300 errors, on top of that I had to convert the code to the newer version of Microsoft Studio or it wouldn't work. After all of that I went into CMake and I showed it the location of Graphics Magick with the GM_PREFIX and I even set Graphics Magick as the WT_RASTERIMAGE_Implementation due to an error I got in CMake about it not being set. I pressed configure and then I went into Wt.sln and it had additional projects show up, about 64 I believe and I tried to get the examples to work from there and it didn't work.

The truth is I am very lost on how to get Graphics Magick to work and even though I followed the instructions I think they are out dated. If anyone could assist me with the best way to do this for Windows Server 2012 R2, Boost 1.60, CMake 3.5.0 with a clean operating system and a fresh build of witty in C:\projects\witty\wt-3.3.5 with my WT folder in C:\Program Files (x86)\WT I would appreciate it so much! I'm sorry this post was so long but I am trying my best to give you all the information possible to show you where I am at. I've tried looking around google searches and youtube videos on this for a long time but I haven't been able to dig up any information on how to get it working so I would really really appreciate the help you could give me! Thanks for your time, Matt

#1

Updated by Koen Deforche over 6 years ago

  • Status changed from New to InProgress
  • Assignee set to Wim Dumon
#2

Updated by Wim Dumon over 6 years ago

  • Status changed from InProgress to Resolved
#3

Updated by Koen Deforche about 6 years ago

  • Status changed from Resolved to Closed
  • Target version set to 3.3.6

Also available in: Atom PDF