Project

General

Profile

Bug #5545

ScrollVisibility js error with IE9, possibly other browsers

Added by Bruce Toll almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
02/09/2017
Due date:
% Done:

0%

Estimated time:

Description

With github wt (3.3.7-rc1-2-g4606fda), the use of setScrollVisibilityEnabled(true) can result in a JS error with IE 9 and possibly other browsers that do not support MutationObserver. This can be observed with IE 9 by scrolling down through the scrollvisibility feature example. The exception_description is "Could not complete the operation due to error 80020101." This appears to be caused by line 146 in ScrollVisibility.js: "mutObserver.disconnect()".

Attached, for your review, is a lightly tested patch that seems to help with this issue.

NOTE: The issue is also likely to be present in wt4, as the same ScrollVisibility.js is used.


Files

#1

Updated by Roel Standaert almost 5 years ago

  • Status changed from New to InProgress
  • Assignee set to André Jacobs
#2

Updated by André Jacobs almost 5 years ago

  • Status changed from InProgress to Implemented @Emweb
  • Assignee deleted (André Jacobs)
#3

Updated by André Jacobs almost 5 years ago

  • Assignee set to André Jacobs
#4

Updated by Roel Standaert almost 5 years ago

  • Status changed from Implemented @Emweb to Resolved
#5

Updated by Roel Standaert over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF