Project

General

Profile

Bug #5596

Wthttpd doesn't take --threads parameter into account.

Added by Kayra Akman almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
03/13/2017
Due date:
% Done:

0%

Estimated time:

Description

I have tried both -t and --threads with values below and above 10. Wthttpd always uses the same number of threads regardless of the -t parameter.

By the way, although default thread count is 10 according to the documentation, the process uses 13 or 14 process.

Wt version: 3.3.6 MSVC2013 64bit, prebuilt binaries by Emweb.

#1

Updated by Roel Standaert almost 6 years ago

I'm not sure about the 2013 version, but I just checked with the latest master (which should become the Wt 3.3.7 release) and VS 2010 and 2015 and the number of threads used is equal to the threads parameter.

The exact number of threads spawned by the application may differ, though. The threads parameter only controls the amount of threads that service the WServer's underlying WIOService. I've noticed a few extra threads, but those are not directly spawned by Wt.

Regards,

Roel

#2

Updated by Kayra Akman almost 6 years ago

The issue is not reproducible with 3.3.7 MSVS2013. Upgrading to 3.3.7 is an acceptable fix.

#3

Updated by Roel Standaert almost 6 years ago

  • Status changed from New to Closed

Also available in: Atom PDF