Project

General

Profile

Feature #5607

wt core requirements

Added by Vasily Pupkin over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Target version:
Start date:
03/20/2017
Due date:
% Done:

0%

Estimated time:

Description

Moving to Wt 4 std smart pointers, what is minimum compiler's versions are going to be?

Is there going to be any macro switch for msvc2010 and gcc 4.4 support?

#1

Updated by Roel Standaert over 5 years ago

  • Status changed from New to Closed

As for Visual Studio, we're testing with Visual Studio 2015 and that's probably the lowest version of Visual Studio we will support.

I think that at the moment Wt 4 can build with at least GCC 4.9, because Wt 4 requires std::regex support.

I think that for Wt 4, it would be a waste of time to try to support compilers without (nearly) full C+11 compliance. Full C+11 support is the minimum requirement for Wt 4.

Also available in: Atom PDF