Project

General

Profile

Feature #5756

IIS - Please add support for newer IIS 10.0 extensions (FastCGI is still there and maybe better as well, plus they also have SimpleCGI)

Added by Osman Zakir over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
06/12/2017
Due date:
% Done:

0%

Estimated time:

Description

IIS 10.0 doesn't seem to have ISAPI anymore (it's only there in IIS versions 6 and 7). So I believe it would be better for Wt to either bring back support for IIS FastCGI and try to optimize it for better support and all, and/or add support for new IIS extensions. Maybe also try to support SimpleCGI, which is like CGI but much simpler.

#1

Updated by Osman Zakir over 5 years ago

Never mind about FastCGI on IIS 10 - that, too, is only supported on IIS 5, 6, and 7.

Just please try to find a protocol/extension service with the greatest support that can work with Wt and that in.

#2

Updated by Wim Dumon over 5 years ago

  • Status changed from New to Resolved

As far as I know, ISAPI is available as an extension module in all IIS versions, and as such ISAPI applications can be installed in newer IIS versions.

While I agree that IIS extension modules is now a better way to support IIS (and has more features than ISAPI), I consider fcgi a dead end (on Windows, Linux, or any platform).

Best regards,

Wim.

#3

Updated by Roel Standaert over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF