Project

General

Profile

Bug #7043

WTableView can lose synchronization and display "Loading" with multiple scrollTo

Added by Bruce Toll over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
05/13/2019
Due date:
% Done:

0%

Estimated time:

Description

With github wt 4.0.5-31-ga05a7c5d, a WTableView will sometimes display "Loading" when data is available. One way this can happen is if multiple scrollTo actions occur in succession.

There is existing code in WTableView.js to handle the case when there is one outstanding scrollTo pending. However, as demonstrated by the attached test program, it is possible to have more than one scrollTo pending. In that case, the best action seems to be to ignore all but the last (to retain synchronization with the server's viewport for the WTableView).

In addition to the test program, a patch that attempts to address the issue is attached for review. It has been lightly tested with the test application.


Files

#1

Updated by Roel Standaert over 3 years ago

  • Status changed from New to Resolved

This should be fixed in commit 628cfd6.

#2

Updated by Roel Standaert over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF