Project

General

Profile

Bug #73

The FastCGI forwarding server only processes requests one at a time.

Added by Koen Deforche almost 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
08/20/2009
Due date:
% Done:

0%

Estimated time:

Description

In shared process mode, only one request is handled despite having multiple threads available.

The problem is the intermediate process (Server.C) that sits in between the web server and the clients (dedicated or shared Wt processes). This server only processes requests one at a time. This should be modified to dispatch request handling in threads (or even better, to use asio... ?)

#1

Updated by Koen Deforche almost 13 years ago

  • Status changed from New to Closed

This has been fixed in Wt 2.99.4

Also available in: Atom PDF