Project

General

Profile

Bug #7914

WPopupMenu in WidgetSet application gives Wt internal error; code: undefined, description: Cannot read property 'display' of undefined

Added by jeroen zpam about 1 month ago. Updated 8 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
12/14/2020
Due date:
% Done:

0%

Estimated time:

Description

I'm turning our Application into a WidgetSet in order to avoid the X-Frame-Options but now I run into a problem. Our submenu is not working in the WidgetSet.

We use wt3.7.0

I can reproduce it by adding a menu in the hello example (see attached file)


Files

Main.cpp (4.75 KB) Main.cpp hello example with menu jeroen zpam, 12/14/2020 11:07 PM

Related issues

Is duplicate of Bug #7912: Accessing WpopupMenu crashes in Widgetset mode. Works fine in regular modeResolvedKorneel Dumon12/14/2020

Actions
#1

Updated by jeroen zpam about 1 month ago

Looking at Bug #7912, outcommented the line that inserts the entrypoint for the application -> same problem

#2

Updated by Prasad Dixit about 1 month ago

I am also having same problem and it seems related: https://redmine.webtoolkit.eu/issues/7912

#3

Updated by Korneel Dumon 8 days ago

  • Status changed from New to Closed

This is indeed the same as #7912. Unfortunately, we don't support wt3 anymore, so there will be no release to fix this.

#4

Updated by Roel Standaert 8 days ago

  • Related to Bug #7912: Accessing WpopupMenu crashes in Widgetset mode. Works fine in regular mode added
#5

Updated by Roel Standaert 8 days ago

  • Related to deleted (Bug #7912: Accessing WpopupMenu crashes in Widgetset mode. Works fine in regular mode)
#6

Updated by Roel Standaert 8 days ago

  • Is duplicate of Bug #7912: Accessing WpopupMenu crashes in Widgetset mode. Works fine in regular mode added

Also available in: Atom PDF