Project

General

Profile

Bug #8135

WMenu submenu itemselected

Added by Jan Hrubeš 5 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
02/24/2021
Due date:
% Done:

0%

Estimated time:

Description

Hi,
this is regression of an 10 years old issue. When using a two-level menu, then the selection is not properly propagated to the parent menu.
Thus ".itemselected .itemselected" css selector do not work.
I have found it in issues #694, #1037 and question https://redmine.webtoolkit.eu/boards/2/topics/13923 .
The regression is in wt4 branch, I have tested it on wt 4.4.0.

Example attached.


Files

helloMenu.cpp (2.21 KB) helloMenu.cpp Jan Hrubeš, 02/24/2021 09:48 AM
helloMenu.cpp (3.38 KB) helloMenu.cpp added workaround Jan Hrubeš, 03/10/2021 07:40 PM
#1

Updated by Korneel Dumon 5 months ago

  • Status changed from New to InProgress
  • Assignee set to Korneel Dumon

Hi,
can you point me to a revision where you still get the old behavior?
I worry about simply selecting the parent item, since that would trigger another itemSelected() signal. Seems to me that might break some code.

#2

Updated by Jan Hrubeš 5 months ago

Hi,
I am migrating from wt-3.2.3 to wt-4.4.0.

I have written a little workaround (see attachment) with a call "select()" on parent menu item (yes, itemSelected() is triggered).
Also when top menu item is selected, then an item in submenu is selected too.
Wt handle when selection do not change (in WMenu::select()) so no infinite calling one from another occurs.
Sequence of actions can be observed with some trace logging (not included).

#3

Updated by Roel Standaert 4 months ago

  • Status changed from InProgress to Implemented @Emweb
  • Target version set to 4.6.0
#4

Updated by Roel Standaert about 2 months ago

  • Status changed from Implemented @Emweb to Resolved

Also available in: Atom PDF