Project

General

Profile

Bug #8577

test.http reports two failing tests related to trusted proxies

Added by Bruce Toll 5 months ago. Updated 19 days ago.

Status:
Resolved
Priority:
Low
Target version:
Start date:
05/24/2021
Due date:
% Done:

100%

Estimated time:

Description

With Wt 4.5.0-rc1-52-g42a5ef9f (github master), I've encountered two test failures with test.http. It may be a mistake on my part with configuration or how I'm running the tests. I've attached the test output, as well as a patch for your review that helps the tests pass in my environment.


Files

#1

Updated by Korneel Dumon 5 months ago

According to the documentation in wt_config.xml, I think it's actually the second test (for Client-IP) that should use the trusted proxy list.

#2

Updated by Bruce Toll 5 months ago

Hi Korneel,

Thanks for following-up. I think you're right. I probably should have just reported the test failures, as the intended behavior of the tests seemed somewhat ambiguous to me. Please disregard the suggested patch.

--Bruce

#3

Updated by Roel Standaert 5 months ago

  • Assignee set to Roel Standaert
  • Target version set to 4.6.0
#4

Updated by Roel Standaert 5 months ago

  • Status changed from New to InProgress
#5

Updated by Roel Standaert 4 months ago

  • Status changed from InProgress to Review
#6

Updated by Roel Standaert 4 months ago

  • Status changed from Review to Resolved
#7

Updated by Roel Standaert 2 months ago

  • % Done changed from 0 to 100
#8

Updated by Roel Standaert 19 days ago

  • Target version changed from 4.6.0 to 4.5.1

Also available in: Atom PDF