Wt with Apache

Added by Rajeev Gajbhiye about 9 years ago


I am trying to get Wt application running on Apache web server by following the instructions mentioned here[[]]. I have remove contexts related to debug. Hence, my wt.conf looks like this.

<IfModule mod_fcgid.c>

NameVirtualHost *:80

<VirtualHost *:80>

# Add this servername into the /etc/hosts file.

#ServerName dummy

#ServerAlias dummy

DocumentRoot /var/www/testwt/docroot

AddHandler fcgid-script wt

DirectoryIndex testwt.wt

Order Deny,Allow

Allow from all

Options +ExecCGI -Indexes

FcgidInitialEnv WT_APP_ROOT /var/www/testwt/approot/

The sample program is compiled as testwt.wt and been placed inside /var/www/testwt/approot/ while 'resources' is stored inside /var/www/testwt/docroot/

I have disabled selinux, created directory /var/run/wt with appropriate permissions and apache as owner & group. However, I am not getting anything to run. I have tried various urls:

  1. localhost
  2. localhost/testwt.wt
  3. localhost/testwt
  4. localhost/wt
    Except for localhost, other urls show me '404 Not Found' error, while the former shows me a welcome page (Fedora Test Page). Tried to see the log file /etc/httpd/logs/error_log. No error shown there. Please guide me on what can be wrong at my end? I have Fedora 19 64 bit.



Replies (2)

RE: Wt with Apache - Added by Rajeev Gajbhiye about 9 years ago

I am now able to get it running. Followed the instructions provided in the link

I observed that mod_fcgid wasn't already installed. Also, had to move testwt.wt to docroot.



RE: Wt with Apache - Added by Koen Deforche about 9 years ago


Does apache's error log provide any hint?

Did you enable the modfcgid module?