Project

General

Profile

Bug #1598

pid_t has not been declared.

Added by Anonymous almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
12/06/2012
Due date:
% Done:

0%

Estimated time:

Description

pid_t has not been declared, so compilation will failed.

It seems to <sys/types.h> must be included in SessionInfo.h.

Mac OSX 10.6.8

Wt is 3.2.3 with Boost.1.52.0

Building CXX object src/http/CMakeFiles/wthttp.dir/Connection.o
[ 86%] Building CXX object src/Wt/Ext/CMakeFiles/wtext.dir/BorderLayoutImpl.o
[ 86%] Building CXX object src/Wt/Ext/CMakeFiles/wtext.dir/Button.o
[ 86%] Building CXX object src/Wt/Ext/CMakeFiles/wtext.dir/Calendar.o
[ 86%] Building CXX object src/fcgi/CMakeFiles/wtfcgi.dir/SessionInfo.o
In file included from /Users/user/src/c++/wt/wt-3.2.3/src/fcgi/SessionInfo.C:6:0:
/Users/user/src/c++/wt/wt-3.2.3/src/fcgi/SessionInfo.h:18:44: error: 'pid_t' has not been declared
/Users/user/src/c++/wt/wt-3.2.3/src/fcgi/SessionInfo.h:21:3: error: 'pid_t' does not name a type
/Users/user/src/c++/wt/wt-3.2.3/src/fcgi/SessionInfo.h:25:3: error: 'pid_t' does not name a type
/Users/user/src/c++/wt/wt-3.2.3/src/fcgi/SessionInfo.C:10:55: error: 'pid_t' has not been declared
/Users/user/src/c++/wt/wt-3.2.3/src/fcgi/SessionInfo.C: In constructor 'Wt::SessionInfo::SessionInfo(std::string, int)':
/Users/user/src/c++/wt/wt-3.2.3/src/fcgi/SessionInfo.C:12:5: error: class 'Wt::SessionInfo' does not have any field named 'childPId_'
make[2]: *** [src/fcgi/CMakeFiles/wtfcgi.dir/SessionInfo.o] Error 1
#1

Updated by Koen Deforche almost 8 years ago

  • Status changed from New to Resolved
  • Assignee set to Koen Deforche

Hey,

Curiously I can't reproduce this, but it seems that including sys/types.h will not hurt either.

Regards,

koe

#2

Updated by Koen Deforche over 7 years ago

  • Target version changed from 3.2.3 to 3.3.0
#3

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF